Outage: Slack
Incident Report for UC Davis
Resolved
Slack has resolved these issues.
Posted Jan 05, 2021 - 07:06 PST
Monitoring
Slack has resolved the primary issues. For any customers unable to access Slack, please reload (CTRL/CMD + R) or restart Slack. If you encounter any trouble, please let Slack know at feedback@slack.com.

Slack has a separate post for the outstanding calendar apps and email notifications trouble.
https://status.slack.com/2021-01/eb968a2103d010bb
Posted Jan 04, 2021 - 12:21 PST
Update
While the issue is largely still ongoing, Slack believes some customers may see improvement in connecting to Slack after a refresh
Posted Jan 04, 2021 - 09:51 PST
Investigating
Slack service is experiencing system-wide issues. The campus and departmental Slack instances are affected. Slack is working on resolving the issue.

https://status.slack.com/2021-01/9ecc1bc75347b6d1

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jan 04, 2021 - 07:22 PST