AggieService Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 08:24 PDT

Investigating

AggieService is currently experiencing a degradation.

Issues:
Slow form submissions
Prompts multiple times for recaptcha
Some fields not being propagated into cases

Staff are investigating the issue, but it appears to be a possible vendor outage (Form Assembly)


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 22, 2025 - 12:56 PDT
This incident affected: AggieService.