Time Reporting System Outage

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted May 18, 2026 - 10:42 PDT

Investigating

TRS is currently experiencing an outage due to an issue related to Grouper services. Users may be unable to access TRS or experience errors when attempting to log in. Our teams are actively investigating and working to restore service as quickly as possible. Updates will be provided as more information becomes available.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted May 18, 2026 - 08:46 PDT
This incident affected: TRS.