Google workspace file upload failures

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 07:24 PST

Monitoring

Technicians have resolved the issue. We will continue to monitor.
Posted Dec 31, 2025 - 13:14 PST

Identified

Users of Google Workspaces are currently unable to upload new files due to a vendor storage issue. We are currently working with the vendor to address the problem as soon as possible. We will provide updates here once the issue has been resolved
Posted Dec 31, 2025 - 09:10 PST