ServiceNow Degradation

Incident Report for UC Davis

Resolved

This incident is resolved with successful update from the emergency change
https://status.ucdavis.edu/incidents/0ypk8psb5l7m
Posted Mar 06, 2026 - 12:30 PST

Investigating

ServiceNow is currently experiencing a degradation. Staff are investigating the issue.

ServiceNow experienced a degradation with the search function after release 19.1.0.
Users are sent to the Service Operations Workspace to view their result instead of the view or workspace they were currently in.

Admins are investigating a solution.

Workarounds available:
Go to List View when searching, then click the item from list view.
Search directly by the task type:
https://ucdavisit.service-now.com/incident_list.do

Common task tables include:

Incidents: incident_list
Catalog Tasks: sc_task_list
Change Tasks: change_task_list
General Tasks: task_list

EX: https://ucdavisit.service-now.com/incident_list.do



----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 02, 2026 - 14:57 PST
This incident affected: ServiceNow.