ServiceNow Degradation
Incident Report for UC Davis
Resolved
This incident has been resolved.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted May 22, 2024 - 16:20 PDT
Monitoring
Monitoring resolution for now. Emergency Change has been implemented
Posted May 21, 2024 - 14:39 PDT
Investigating
ServiceNow is experiencing delays in email processing.

Staff are investigating the issue and actively working on the resolution.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted May 21, 2024 - 09:10 PDT
This incident affected: ServiceNow.