Voice Telephone System Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jul 23, 2025 - 11:12 PDT

Investigating

We have received reports of intermittent audio issues with incoming calls. Engineers are investigating.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jul 22, 2025 - 14:44 PDT
This incident affected: Voice Telephone System.