Degradation: Campus Telephone Services

Incident Report for UC Davis

Resolved

This issue has been resolved.
Posted Dec 23, 2025 - 17:57 PST

Monitoring

A fix has been implemented and staff is currently monitoring the affected services.
Posted Dec 23, 2025 - 09:20 PST

Investigating

Campus telephone services are currently experiencing a degradation. Staff are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Dec 23, 2025 - 07:57 PST
This incident affected: Voicemail and Voice Telephone System.