A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2025 - 13:34 PST
Identified
Information and Educational Technology (IET) is aware of an issue affecting final grade submissions. Only the primary instructor listed for a course is currently able to submit final grades. In courses with multiple instructors, secondary instructors are unable to submit grades.
Our teams are working to address this issue with urgency.
Affected Classes: Classes with more than one instructor. Final grades can be submitted by one instructor of record, but not all of them.
---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)
Posted Dec 12, 2025 - 16:05 PST
Investigating
The Final Grading System is currently experiencing a degradation.
Staff have identified the issue and are working on a solution.
Affected Classes: Classes with more than one instructor. Final grades can be submitted by one instructor of record, but not all of them.
---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)
Posted Dec 12, 2025 - 15:34 PST
This incident affected: Final Grading System (FGS) direct web access.