Licensing reallocation has been completed for the enterprise. For any further licensing questions, issues, or concerns, please contact IT Express.
Posted Dec 18, 2025 - 15:41 PST
Monitoring
Admins have reallocated available Microsoft licenses to address the removal of the desktop benefit from the free A1 license. We will be working with campus stakeholders on a permanent solution. In the meantime please report to IT Express if you are still encountering issues.
Posted Nov 05, 2025 - 15:32 PST
Identified
Microsoft has identified the issue, and the uConnect team is implementing a resolution for the issue
Posted Oct 31, 2025 - 12:03 PDT
Investigating
uConnect Office 365 is currently experiencing a degradation.
Some users are receiving an error when attempting to install or use the Microsoft Office 365 Desktop application. The web version of the applications remains available for use.
A support ticket with Microsoft has been opened to resolve the issue.
---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)