Outage: Time Reporting System (TRS)

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 13:29 PDT

Investigating

Time Reporting System (TRS) is currently experiencing an outage. Staff expect the service to be restored in less than an hour.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Oct 10, 2025 - 13:15 PDT
This incident affected: TRS.