Microsoft 365 Services Degradation

Incident Report for UC Davis

Resolved

The vendor has fixed the problem.

This is resolved.
Posted Jan 23, 2026 - 08:55 PST

Investigating

Microsoft 365 Services is currently experiencing a degradation.

Microsoft is investigating a potential issue impacting multiple Microsoft 365 services, including Outlook, Microsoft Defender and Microsoft Purview.
Further information can be found in the admin center under MO1221364.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jan 22, 2026 - 12:01 PST
This incident affected: uConnect Office 365.