Box.com Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved by the vendor.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 17, 2026 - 13:40 PDT

Monitoring

The vendor has updated the degradation to monitoring. "Our team has taken steps to remediate this issue and is seeing improvement for Box Webapp service. We are continuing to monitor for any additional impact."


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 17, 2026 - 12:46 PDT

Investigating

Box.com is experiencing a degradation. The vendor is aware and is actively working on a resolution. Users may experience intermittent failures when loading the "All files" page and subfolders.

More info from the vendor is available here: https://status.box.com/incidents/0ws7h1m5npqw


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 17, 2026 - 12:44 PDT
This incident affected: Box.