Canvas Outage

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:03 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:42 PDT

Investigating

Canvas is currently down due to large parts of AWS being down.
https://status.instructure.com/
Posted Oct 20, 2025 - 07:39 PDT
This incident affected: Canvas.