GS eDocs Degradation
Incident Report for UC Davis
Resolved
GS eDocs service has been restored.
Posted Aug 26, 2024 - 11:12 PDT
Investigating
The eDocs service is responding to a 503 error code. The dev team is investigating this issue.
Posted Aug 26, 2024 - 10:19 PDT
This incident affected: GS eDocs.