DavisMail degradation
Incident Report for UC Davis
Resolved
Administrators determined that some email sent to DavisMail between Wednesday at approximately 7:00pm and Thursday at 1:00pm was not delivered correctly. The delivery problem has been resolved and the missing email has been restored
Posted Mar 27, 2020 - 13:04 PDT
Investigating
IT Express has received reports of DavisMail users not receiving mail. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 26, 2020 - 12:29 PDT
This incident affected: DavisMail.