Office 365 / Outlook Degradation
Incident Report for UC Davis
Resolved
Final Update:
31/03/2023 09:10:00 AM – Deployment of the fix to revert the offending change is complete, and Microsoft’s service telemetry has confirmed that access to the affected mailboxes is restored and impact is remediated.

This incident is resolved.
Posted Apr 03, 2023 - 10:07 PDT
Update
Microsoft has identified a problem with their service and is working to resolve it. UC Davis customers are having fewer problems after a change implemented on the campus side yesterday.
Posted Mar 30, 2023 - 12:24 PDT
Monitoring
Systems admins implemented a change which appears to be fixing the issue for clients. Affected clients should resolve the issue within four hours.
Posted Mar 29, 2023 - 12:57 PDT
Investigating
Some users with in-place archive mailboxes in Exchange Online are experiencing repeated login prompts in Microsoft Outlook.

Admins are investigating the problem with the vendor.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 29, 2023 - 07:44 PDT
This incident affected: uConnect Office 365.