Inbound Phone Call Degradation

Incident Report for UC Davis

Resolved

We have mitigated the issue with a temporary fix and will work our carrier to implement and coordinate the long term solution.
Posted Apr 06, 2026 - 10:31 PDT

Identified

The root cause of the inbound call issue has been identified and a temporary fix has been put in place. Inbound calling has been restored.
Posted Apr 03, 2026 - 10:29 PDT

Investigating

There is currently an issue impacting inbound phone calls coming from outside of UC Davis. Internal calls and outbound calls from UCD are unaffected. Technicians are investigating.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 03, 2026 - 09:32 PDT
This incident affected: Voice Telephone System.