International Student Service Outage
Incident Report for UC Davis
Resolved
System Administrators resolved this issue.
Posted Apr 17, 2024 - 22:23 PDT
Investigating
International Student Service is currently experiencing an outage. System Administrators are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 13, 2024 - 09:27 PDT