Email Degradation
Incident Report for UC Davis
Resolved
Outgoing email for UCDHS users to external addresses were delayed by an hour due to a misconfiguration.
Posted Jul 26, 2024 - 08:27 PDT
Investigating
Email is currently experiencing a degradation.

Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jul 26, 2024 - 07:25 PDT
This incident affected: Email Routing.