Box.com Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 16, 2025 - 07:11 PDT

Investigating

Box.com is currently experiencing a degradation. The vendor is investigating the issue. Additional information is available on the vendor's status page: https://status.box.com/


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 12, 2025 - 11:46 PDT
This incident affected: Box.