myadmissions.ucdavis.edu Degradation

Incident Report for UC Davis

Resolved

Staff identified and addressed a high load of connections and service was restored.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 10, 2025 - 09:25 PDT

Investigating

The myadmissions.ucdavis.edu website is experiencing slow performance due to high load, staff are investigating.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 07, 2025 - 15:51 PST