CAS SSO Degradation

Incident Report for UC Davis

Resolved

The system recovered itself after brief time of performance degradation.
Posted Apr 29, 2026 - 09:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 15:12 PDT

Investigating

The CAS SSO system is currently experiencing a performance degradation. Staff are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 28, 2026 - 12:32 PDT
This incident affected: CAS.