Box.com Outage

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 09:19 PDT

Monitoring

Box update:
Monitoring - A fix has been implemented and we are monitoring the results.
Sep 04, 2025 - 11:45 PDT
Posted Sep 04, 2025 - 11:56 PDT

Update

Box.com is currently experiencing an outage.

Box.com staff are investigating. https://status.box.com/
Investigating - We are investigating an ongoing issue affecting Box. Users may experience errors or long load times using Box services. We will provide more information as soon as it is available.
Sep 04, 2025 - 11:20 PDT
Posted Sep 04, 2025 - 11:30 PDT

Investigating

Box.com is currently experiencing an outage.

Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Sep 04, 2025 - 11:14 PDT
This incident affected: Box.