Duo Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 14, 2025 - 08:18 PST

Monitoring

The vendor is now indicating that Duo services have been restored. Staff is currently monitoring the system.
Posted Feb 13, 2025 - 16:35 PST

Update

Duo SMS and callback authentication should be operational once again. Device management is still impacted by the degradation and unavailable to register new devices.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 13, 2025 - 15:26 PST

Update

The degradation is ongoing with the vendor, Duo. We will continue to monitor https://status.duo.com for updates or a resolution.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 13, 2025 - 13:48 PST

Update

The vendor is still working on a fix for Duo.

Using the Duo Push option is highly encouraged for those who have the Duo Mobile App installed.

Additionally, the Duo Device Management Portal is currently down. Users cannot register new phone or devices at the moment.
Posted Feb 13, 2025 - 12:06 PST

Identified

The vendor, Duo, provided the following update on https://status.duo.com/incidents/h7lht3g1zv9w

"We have identified the issue causing Admin Panel login, Device Management Portal, Risk-based Authentication, and SMS/Phone Call delivery failures across all deployments and are working to deploy a fix."


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 13, 2025 - 11:11 PST

Update

The vendor, Duo, is currently experiencing an outage and has provided the following update on https://status.duo.com/incidents/h7lht3g1zv9w

"We are currently investigating an issue causing Admin Panel login and SMS/Phone Call delivery failures across all deployments.

If you can access your Admin Panel, please utilize our other MFA methods such as Push, Passcodes, Hardware Tokens, and Security Keys in the meantime. https://duo.com/docs/policy#authentication-methods"


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 13, 2025 - 10:52 PST

Update

DUO continues to investigate this issue.

Please see their page for most up to date data: https://status.duo.com
Posted Feb 13, 2025 - 10:50 PST

Investigating

Duo is currently experiencing a degradation. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Feb 13, 2025 - 10:27 PST
This incident affected: Duo Multifactor Authentication.