Degradation: Canvas
Incident Report for UC Davis
Resolved
Canvas engineers implemented a fix to resolve the issue. UC Davis admins monitored and the issue did not recur.
Posted Jun 17, 2024 - 09:57 PDT
Monitoring
Canvas engineers have implemented a fix and feel they have resolved the issue. UC Davis admins will continue to monitor the service.
Posted Jun 12, 2024 - 11:18 PDT
Investigating
Users may be encountering the following error, “This website is under heavy load (request timed out)“ when attempting to access UC Davis Canvas. This issue is impacting many Canvas institutions. Canvas engineers are aware of the issue and working on a fix. For most up to date status please visit:

https://status.instructure.com/incidents/ppys6br1pkkw

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 12, 2024 - 10:39 PDT
This incident affected: Canvas.