ServiceNow Degradation

Incident Report for UC Davis

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 10:39 PDT

Identified

ServiceNow vendor has identified an issue in their last patch and has provided a script to resolve the issue. This is being implemented in a lower environment and an Emergency Change is being opened to apply to Prod as quickly as possible
Posted Mar 06, 2026 - 12:04 PST

Investigating

ServiceNow emails stopped processing again around 2:30am on 3/6/2026. Inbound emails to the platform have not been processing and new tickets/ current items have not been created or updated.

Admins are reaching out to the vendor for assistance and continue to investigate.
Posted Mar 06, 2026 - 09:42 PST

Monitoring

Emails have all been processed however admins will keep this open for monitoring until tomorrow.
Posted Mar 05, 2026 - 16:10 PST

Investigating

ServiceNow is experiencing degraded performance. Since 3:00 AM PT on 3/5/2026, inbound email to the platform has not been processing and tickets/items have not been created or updated.


Admins are investigating.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 05, 2026 - 10:44 PST
This incident affected: ServiceNow.