Microsoft Office 365 Degradation

Incident Report for UC Davis

Resolved

Microsoft has identified and resolved the issue
Posted Oct 31, 2025 - 09:08 PDT

Investigating

Microsoft Office 365 has is currently experiencing a service degradation.

Users may see impacts to the following:
- Access to some Microsoft Entra, Microsoft Purview, Microsoft Defender, Microsoft Power Apps and Microsoft Intune functions. For example, Microsoft Defender for Cloud Apps policies may not be applying as expected.
- Access to security.microsoft.com, learn.microsoft.com, and other portals accessed through microsoft.com.
- Add-ins and network connectivity in Outlook.
- Degraded functionality to some workflows within Microsoft Teams, including impact to location data in support of emergency calls.

Admins are looking at Microsoft is currently investigating the issue.
https://status.cloud.microsoft/


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Oct 29, 2025 - 12:14 PDT
This incident affected: uConnect Office 365.