Box.com Outage
Incident Report for UC Davis
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 08:00 PDT
Update
Box.com has resolved their issue and have marked all systems operational.
Posted Jul 09, 2020 - 08:00 PDT
Identified
Box.com has identified the cause of this issue and is working to resolve. For more information, please visit https://status.box.com/incidents/kxlq980nk5xl.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jul 08, 2020 - 18:02 PDT
Investigating
Box.com is currently experiencing an outage. For more information, please visit https://status.box.com/incidents/kxlq980nk5xl.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jul 08, 2020 - 16:15 PDT
This incident affected: Box.