---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)
Posted Feb 23, 2026 - 09:14 PST
Monitoring
Admins have applied new certificates that should resolve the issue. We will continue to monitor.
---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)
Posted Feb 19, 2026 - 15:41 PST
Investigating
The F5 redirect service is currently experiencing degraded service. The service is used to redirect URLs, such as kb.ucdavis.edu, to the actual URL for quick access to some of our websites. A partial list of the sites impacted include: kb.ucdavis.edu, passphrase.ucdavis.edu, and finesse.ucdavis.edu. Users are receiving an unexpected error titled "This connection Is Not Private". We are troubleshooting the issue now, and will provide an update as progress is made.
---------------------------- IT Express Service Desk ithelp@ucdavis.edu 530.754.HELP (4357)