MyAdmissions Degradation
Incident Report for UC Davis
Resolved
MyAdmissions website functionality has been restored and is available for use.
Posted Apr 23, 2015 - 13:38 PDT
Investigating
The MyAdmissions website is currently experiencing degraded service. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 23, 2015 - 13:11 PDT