OWA authentication Outage
Incident Report for UC Davis
Resolved
Authentication via owa.ucdavis.edu has been returned to normal service.
Posted Aug 14, 2015 - 14:27 PDT
Monitoring
uConnect administrators have identified and fixed the issue for owa.ucdavis.edu and are monitoring the service.
Posted Aug 14, 2015 - 13:36 PDT
Investigating
Authentication at owa.ucdavis.edu is currently experiencing an outage, some customers are reporting that they receive a blank page after logging in. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Aug 14, 2015 - 13:20 PDT
This incident affected: uConnect Exchange On-prem.