Outage: UC Davis Telephone Directory Line
Incident Report for UC Davis
Resolved
The campus directory number as been restored.
Posted 4 days ago. Sep 10, 2019 - 14:56 PDT
Investigating
Calls to 530-752-1011, the campus directory number, are currently failing. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted 4 days ago. Sep 10, 2019 - 13:50 PDT
This incident affected: Voice Telephone System.