Degradation: Google Keep app
Incident Report for UC Davis
Resolved
This incident has been resolved.
Posted May 12, 2022 - 09:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2022 - 07:56 PDT
Investigating
Google Keep is currently experiencing an outage. Staff are investigating the issue.


----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted May 12, 2022 - 07:15 PDT
This incident affected: DavisMail.