Degradation: DavisMail
Incident Report for UC Davis
Resolved
Google has resolved the sign-in degradation. More information available here: https://status.cloud.google.com/incident/cloud-iam/19001
Posted Apr 17, 2019 - 17:29 PDT
Investigating
DavisMail is experiencing authentication issues. We will update the status as more information becomes available from Google.
Posted Apr 17, 2019 - 15:48 PDT
This incident affected: DavisMail.