Degradation: Office 365 services
Incident Report for UC Davis
Resolved
Microsoft has resolved the issue and staff have seen no re-occurrence of symptoms related to this issue.
Posted Nov 13, 2018 - 10:56 PST
Monitoring
Microsoft has implemented a fix and the issue appears to be resolved. Staff are continuing to monitor the service.
Posted Nov 13, 2018 - 09:53 PST
Investigating
Office 365 services including email are currently experiencing an degradation with some customers having slow load times and/or failure to send/receive messages. Staff are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Nov 13, 2018 - 07:48 PST
This incident affected: uConnect Office 365.