Faculty Sites Services Degradation
Incident Report for UC Davis
Resolved
The Faculty Sites degradation has been resolved.
Posted Jun 14, 2019 - 10:32 PDT
Monitoring
Faculty sites are currently experiencing degraded service. Some sites are unavailable or are loading slowly. Staff are monitoring the issue.
Please continue to report any issues to IT Express.
530-752-4357
ithelp@ucdavis.edu
7 am to 6 pm PST Monday through Friday, closed university holidays
Posted Jun 10, 2019 - 10:16 PDT
This incident affected: Faculty Sites Services.