Outage: Microsoft Safe Links
Incident Report for UC Davis
Resolved
Microsoft has resolved the issue with their Safe Link service.
Posted 3 months ago. Jan 30, 2019 - 10:30 PST
Update
Individuals can use http://www.o365atp.com/ to decode Safe Link URLS while Microsoft works to resolve this issue.
Posted 3 months ago. Jan 29, 2019 - 11:33 PST
Identified
Microsoft is reporting issues with their Safe Link service that is affecting some UC Davis Office 365 email accounts.

User Impact: Users are receiving 503 errors when attempting to access URLs within email messages.

More info: Users may also be unable to access Safe Links URLs via multiple Microsoft 365 services.

Current status: Microsoft is continuing to review Safe Link and networking logs to further isolate the cause of the problem. Additionally, they are rerouting traffic through alternate infrastructure to improve the end-user experience.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted 3 months ago. Jan 29, 2019 - 08:56 PST
This incident affected: uConnect Office 365.