Degradation: Duo
Incident Report for UC Davis
Resolved
Duo has resolved the issue with telephone call authentication.
Posted Nov 05, 2018 - 13:38 PST
Monitoring
Duo has implemented a fix for the telephone call authentication method and are monitoring the issue.
Posted Nov 05, 2018 - 08:16 PST
Update
Duo is investigation this issue;
https://status.duo.com/incidents/x15xz0vf8wkn
Posted Nov 05, 2018 - 07:40 PST
Investigating
Duo multi-factor authentication for telephone calls is failing, push and passcode options are still working. Staff are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Nov 05, 2018 - 07:19 PST
This incident affected: Duo Multifactor Authentication.