Software Website Outage
Incident Report for UC Davis
Resolved
System administrators have resolved the issue impacting the software website.
Posted 4 months ago. Jan 02, 2018 - 10:20 PST
Investigating
The Software website, software.ucdavis.edu, is currently down. System administrators have been notified and are investigating.
Posted 4 months ago. Jan 02, 2018 - 08:45 PST
This incident affected: Software Website.