Degardation: myUCDavis
Incident Report for UC Davis
Resolved
The MyUCDavis service has remained stable following the fix and MyUCDavis admins are resolving this issue.
Posted Apr 12, 2019 - 14:10 PDT
Monitoring
Admins are monitoring issues with myUCDavis being inaccessible for some users.
Posted Apr 08, 2019 - 12:05 PDT
This incident affected: myUCDavis.