Degredation uConnect Office 365 Exchange Online
Incident Report for UC Davis
Resolved
Microsoft has resolved the Office365 issues and the service has been returned to normal service.
Posted May 13, 2015 - 14:47 PDT
Investigating
Some users have reported mailbox logon problems. Microsoft Engineering has confirmed that the issue is related to Exchange Online services. Administrators are investigating the issue.
Posted May 12, 2015 - 18:30 PDT
This incident affected: uConnect Active Directory, uConnect Exchange On-prem, and uConnect Office 365.