Security.ucdavis.edu Outage
Incident Report for UC Davis
Resolved
security.ucdavis.edu can be accessed through the secure site https://security.ucdavis.edu
Posted Jan 29, 2016 - 21:04 PST
Investigating
Security.ucdavis.edu is currently experiencing an outage. Staff are investigating the issue.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jan 29, 2016 - 17:43 PST