Email Delay
Incident Report for UC Davis
Resolved
Administrators have restarted the impacted server and emails are routing as expected.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 31, 2015 - 15:39 PDT
Investigating
Some Individuals are reporting email delays from external services to their UC Davis email.
Administrators are looking into the issue.
Posted Mar 31, 2015 - 14:34 PDT
This incident affected: Email Routing.