ServiceNow Degradation
Incident Report for UC Davis
Resolved
The root cause for the reported degradation was related to mail routing issues.
Posted Apr 17, 2017 - 11:33 PDT
Investigating
Automated incident creation may be delayed by approximately 30 minutes. (This applies to incidents created via email only - other services, such as ServiceHub, are not impacted)

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Apr 16, 2017 - 16:17 PDT
This incident affected: ServiceNow.