uConnect new mailboxes outage
Incident Report for UC Davis
Resolved
By 3PM Wednesday, system administrators had identified and resolved the root cause of the dysfunction in the provisioning sub-system.
Posted 14 days ago. Sep 07, 2017 - 12:14 PDT
Identified
Automatic provisioning of new mailboxes in Exchange Online is currently not functioning. We expect to resolve the outage by noon Wednesday.
Posted 15 days ago. Sep 05, 2017 - 21:08 PDT