non UC Davis emails going to Junk Folder
Incident Report for UC Davis
Resolved
Administrators have applied a permanent fix and verified this issue is resolved.
Posted May 27, 2015 - 15:56 PDT
Monitoring
Administrators have placed a workaround and email routing has returned to service. Administrators will continue to monitor the routing while a permanent fix is applied.
Posted May 21, 2015 - 11:06 PDT
Investigating
Users on Office 365 have reported that non UC Davis emails are going straight to their Junk Email folder. System administrators are investigating this issue.
Posted May 21, 2015 - 08:51 PDT
This incident affected: Email Routing and uConnect Office 365.