Box Service Delays: Previews and Downloads
Incident Report for UC Davis
Resolved
Box engineers have resolved the issue with recently upload files not being viewable and downloadable. For more information about Box status please see status.box.com.
Posted Jul 09, 2014 - 13:42 PDT
Identified
Box is currently experiencing a technical issue with its WebApp service. The initial description of the issue is as follows:

As of 8:14am PDT, some newly uploaded files may not be instantly previewed nor downloadable.

Box engineers are actively working towards a resolution. Box will update UC Davis as soon as they have more information on this issue and a projected time to resolution. Updates are also available at status.box.com.
Posted Jul 09, 2014 - 11:18 PDT
This incident affected: Box.