SMTP Undeliverable Messages
Incident Report for UC Davis
Resolved
Over the weekend a compromised UC Davis computing account led the UC Davis email servers to be listed on several anti-phishing block lists. IET staff have been working with the list maintainers to get delisted and have closed the compromised account. At this time emails should be able to get to their intended recipients
Posted Mar 24, 2015 - 10:42 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2015 - 10:40 PDT
Investigating
We have received reports of users receiving error messages when sending to known recipients using their campus mail. An example of the error message may include similar text:

"A communication failure occurred during the delivery of this message. Please try resending the message later. If the problem continues, contact your help desk."

IT Express has notified system administrators who are currently investigating
----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Mar 23, 2015 - 09:23 PDT
This incident affected: Email Routing.