Network Outage: Infoblox DNS/DHCP Administrative Functions
Incident Report for UC Davis
Postmortem

The Infoblox restart services permissions issue has been resolved with a recent update and configuration change. Department admins are once again able to perform the restart services function.


IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)

Posted Jun 20, 2016 - 14:53 PDT

Resolved
The administrative restart function remains non-functional. The vendor states this will be fixed with the next software update expected in late June. In the meantime the infoblox server will automatically restart every hour to reload configuration changes.
Posted May 26, 2016 - 22:53 PDT
Update
The recently applied patch corrected an error that was occurring when a restart of services was performed from a super user account. The 'Restart Services' function that is needed when DHCP ranges/hosts/filters are added/changed is still not available for Department Administrator accounts. The problem will be corrected with the next release of NIOS software. The software release is expected sometime in mid-late June.
Posted May 26, 2016 - 12:44 PDT
Update
The vendor supplied patch did not fix the problem, and we continue to investigate and work with the vendor to resolve the issue.
Posted May 26, 2016 - 10:04 PDT
Identified
System administrators have acquired a software patch from the vendor and will be deploying the patch tomorrow, Friday May 20th at 5:00am.
Posted May 19, 2016 - 14:26 PDT
Investigating
Impact:
The 'Restart Services' function that is needed when DHCP ranges/hosts/filters are added/changed is not available for Department Administrator accounts. The vendor is currently working on a fix for this bug. As a workaround, the Restart Services function has been scheduled to run on an hourly basis.

Locations Affected:
When a department network administrator makes a change to a DHCP range, or IPv4 filter, a restart services is required in order for that change to take effect. The restart services function is currently not available to Department Admin accounts. Only superuser accounts currently have the ability to perform a restart services.

Status:
The Restart Services function has been scheduled to run on an hourly basis. This will remain until the vendor releases a software update that includes the fix for this bug.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted May 05, 2016 - 10:58 PDT
This incident affected: DHCP, DNS, and Network.